Gradle 5.x (we use 5.4.1) is required for Corda OS 4.3, but this isn’t mentioned in the release docs (https://docs.corda.net/releases/release-V4.3/app-upgrade-notes.html).
In fact it explicitly states:
You should also ensure you’re using Gradle 4.10 (but not 5). If you use the Gradle wrapper, run:
Which is incorrect for 4.3
Additionally, the upgrade to Gradle 5.4.1 also requires the addition of an additional repository https://repo.gradle.org/gradle/libs-releases or the project will fail to compile because it is unable to find the gradle-api-tooling dependency.
https://software.r3.com/artifactory/corda/org/gradle/gradle-tooling-api/ Only has v4.10.1. Corda v4.3 requires v5.4.1
This is a problem because when Clients follow the getting started instruction on v4.3 https://docs.corda.net/quickstart-build.html it instructs them to download https://github.com/corda/cordapp-template-kotlin.git
When the clients follow these instructions the Cordapp won't compile, as this is the starting point for all new users of corda v4.3 it is likely to impact many people.
An open source contributor has proposed a pull request to fix by adding the direct dependancy into the template's gradle.build file, but I think it needs updating in the Corda Artifcatory to keep the dependencies clean. See the pull request: https://github.com/corda/cordapp-template-kotlin/pull/68 for details