Unable to build implicit-cordapp-upgrades with corda_release_version = '4.3-RC01' (doc fix)

Description

Steps to reproduce:

1) Get code from https://github.com/corda/samples branch 4.3-RC01
2) Change build.gradle

1 2 3 ... corda_release_version = '4.3-RC01' ...

3) Run task from implicit-cordapp-upgrades

1 ./gradlew deployNodes

4) Check output

Expected result:
cordapp is built, nodes are deployed

Actual result:
error during build

1 2 3 e: /home/thecanonmaster/R3/code/samples-4.3-RC01/implicit-cordapp-upgrades/workflows/v3-can-default/src/main/kotlin/net/corda/examples/obligation/workflow/flows/IssueObligation.kt: (94, 39): Type mismatch: inferred type is Any but AbstractParty was expected e: /home/thecanonmaster/R3/code/samples-4.3-RC01/implicit-cordapp-upgrades/workflows/v3-can-default/src/main/kotlin/net/corda/examples/obligation/workflow/flows/IssueObligation.kt: (94, 49): Type mismatch: inferred type is Any but AbstractParty was expected > Task :workflows:v3-can-default:compileKotlin FAILED

 

Status

Assignee

Viktor Kolomeyko

Reporter

Dmitry Toropov

Priority

High

Fix versions

Ported to...

Corda 4.3

Feature Team

Kernel Group

Severity

Medium

Sprint

None

Affects versions

Corda 4.3 RC01
Configure