Nondescript error messaging for cases where CorDapp min platform version is beneath Network MPV

Description

When a CorDapp MPV is below the network MPV, the following error message is put into the Node logs. This doesn't provide enough information to the user as to what might have gone wrong.

[WARN ] 2019-06-14T15:54:14,096Z [main] internal.Node.logLoadedCorDapps - Found 1 CorDapp(s) with unknown information. They will be unable to run on Corda in the future.

Status

Assignee

Szymon Sztuka

Reporter

nick.rogers

Labels

Priority

Medium

Fix versions

None

Ported to...

None

Feature Team

Operational Experience

CVSS Vector

None

Severity

Medium

Sprint

None

Affects versions

Configure