Uploaded image for project: 'Corda'
  1. CORDA-1737

Update jolokia dependency in cordformation

    Details

    • Feature Team:
      Corda Core
    • Story Points:
      3
    • Sprint:

      Description

      Cordformation (in corda-gradle-plugins) defaults to an insecure version of Jolokia agent (1.3.7) if the version is not found in a project's build settings.

      Update all hardcoded references to jolokia 1.3.7 to the latest version (1.6.0)

      A proper fix would be to not included jolokia at all if it isn't explicitly references in build.gradle, or remove the dependency entirely from cordformation and engineer a better way to instrument nodes with different agent/drivers

        Attachments

          Issue links

            Activity

              People

              • Assignee:
                James.Brown James Brown
                Reporter:
                James.Brown James Brown
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: